301661fc7b72ee9fd72eb668efb11e6665082f82
[gentoo.git] / dev-python / pychm / pychm-0.8.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python bindings for the chmlib library"
11 HOMEPAGE="https://github.com/dottedmag/pychm"
12 SRC_URI="https://github.com/dottedmag/pychm/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~ppc ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="dev-libs/chmlib"
21 DEPEND="${RDEPEND}
22         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
23
24 python_test() {
25         pytest -vv || die
26 }