dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-python / pycares / pycares-3.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python interface for c-ares"
10 HOMEPAGE="https://github.com/saghul/pycares/"
11 SRC_URI="https://github.com/saghul/pycares/archive/${P/_p/-fix}.tar.gz"
12 S=${WORKDIR}/${PN}-${P/_p/-fix}
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm64 ~x86"
17 IUSE=""
18 # Tests fail with network-sandbox, since they try to resolve google.com
19 RESTRICT="test"
20
21 # uses bundled/patched c-ares
22 RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
23 BDEPEND=${RDEPEND}
24
25 python_test() {
26         "${EPYTHON}" tests/tests.py -v || die
27 }