c5b8121e6702440eaf7adbcdddaae7f0dc3e712a
[gentoo.git] / dev-python / pybluez / pybluez-0.22.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
7
8 inherit distutils-r1
9
10 MY_P="PyBluez-${PV}"
11
12 DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
13 HOMEPAGE="https://github.com/karulis/pybluez"
14 SRC_URI="mirror://pypi/P/PyBluez/${MY_P}.zip"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~ppc ~x86"
19 IUSE="examples"
20
21 RDEPEND="net-wireless/bluez"
22 DEPEND="${RDEPEND}
23         app-arch/unzip"
24
25 S=${WORKDIR}/${MY_P}
26
27 python_install_all() {
28         distutils-r1_python_install_all
29         if use examples; then
30                 dodoc -r examples
31                 docompress -x usr/share/doc/${PF}/examples
32         fi
33 }