sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / pybluez / pybluez-0.18-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 MY_P="PyBluez-${PV}"
11
12 DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
13 HOMEPAGE="https://github.com/karulis/pybluez"
14 SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 ppc x86"
19 IUSE="examples"
20
21 DEPEND="net-wireless/bluez"
22 RDEPEND="${DEPEND}"
23
24 S=${WORKDIR}/${MY_P}
25
26 python_install_all() {
27         if use examples; then
28                 dodoc -r examples
29                 docompress -x /usr/share/doc/${PF}/examples
30         fi
31
32         distutils-r1_python_install_all
33 }