dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / pyaes / pyaes-1.6.1-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DISTUTILS_USE_SETUPTOOLS=no
7 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
12 HOMEPAGE="https://pypi.org/project/pyaes/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 DEPEND="test? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )"
22
23 python_test() {
24         local t fail=
25         for t in tests/test-*.py; do
26                 einfo "${t}"
27                 "${EPYTHON}" "${t}" || fail=1
28         done
29         [[ ${fail} ]] && die "Tests fail with ${EPYTHON}"
30 }