x11-themes/gentoo10-backgrounds: Cleanup per bug #85210
[gentoo.git] / dev-python / pudge / pudge-0.1.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A documentation generator for Python projects, using Restructured Text"
11 HOMEPAGE="http://pudge.lesscode.org https://pypi.python.org/pypi/pudge"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="doc"
18
19 RDEPEND="dev-python/docutils[${PYTHON_USEDEP}]
20         >=dev-python/kid-0.9.5[${PYTHON_USEDEP}]
21         dev-python/pygments[${PYTHON_USEDEP}]"
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
23         doc? ( ${RDEPEND} )"
24
25 python_compile_all() {
26         if use doc; then
27                 einfo "Generation of documentation"
28                 "${PYTHON}" bin/pudge --modules=pudge --documents=doc/index.rst --dest=doc/html \
29                 || die "Generation of documentation failed"
30         fi
31 }
32
33 python_install_all() {
34         use doc && local HTML_DOCS=( doc/html/. )
35         distutils-r1_python_install_all
36 }