b1d6c2d4302db1c2cf89002e5134a9c3d5696fb5
[gentoo.git] / dev-python / progressbar / progressbar-2.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Text progressbar library for python"
11 HOMEPAGE="https://pypi.org/project/progressbar/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="|| ( LGPL-2.1 BSD )"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 DEPEND="${BDEPEND}"