dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / polygon / polygon-2.0.6.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Python package to handle polygonal shapes in 2D"
10 HOMEPAGE="https://www.j-raedler.de/projects/polygon/"
11 SRC_URI="https://www.bitbucket.org/jraedler/${PN}2/downloads/Polygon2-${PV}.zip"
12
13 LICENSE="LGPL-2"
14 SLOT="2"
15 KEYWORDS="amd64 ppc x86"
16
17 DEPEND="app-arch/unzip"
18
19 S=${WORKDIR}/Polygon2-${PV}
20
21 DOCS=( HISTORY doc/Polygon.txt )
22
23 python_test() {
24         ${PYTHON} test/Test.py || die "Tests failed"
25 }