dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / pockets / pockets-0.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5} )
7
8 inherit distutils-r1
9
10 IUSE="test"
11
12 DESCRIPTION="A collection of helpful Python tools"
13 HOMEPAGE="https://pypi.python.org/pypi/pockets"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64"
19
20 DEPEND="
21         >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
22         dev-python/sphinx[${PYTHON_USEDEP}]
23         >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
24         >=dev-python/flake8-2.3.0[${PYTHON_USEDEP}]
25         test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
26                 dev-python/nose[${PYTHON_USEDEP}]
27               )
28         dev-python/setuptools[${PYTHON_USEDEP}]
29
30 "
31 src_prepare() {
32         epatch "${FILESDIR}/no_installed_tests.patch" || die
33 }
34 python_test() {
35         nosetests tests || die "tests failed with ${EPYTHON}"
36 }