dev-python/jaraco-classes: change my email in metadata.xml
[gentoo.git] / dev-python / pipenv / pipenv-9.0.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python Development Workflow for Humans"
11 HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
12 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 RDEPEND=""
20 DEPEND="${RDEPEND}
21         dev-python/flake8
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
24         >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
25         >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
26         >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
27         test? (
28                 dev-python/flake8[${PYTHON_USEDEP}]
29                 dev-python/pytest[${PYTHON_USEDEP}]
30         )"
31
32 # not completely packed
33 # requires networking
34 RESTRICT="test"
35
36 python_test() {
37         py.test -v -v || die
38 }