d6b00298e81631214604bc3179306259919b2a1a
[gentoo.git] / dev-python / pdoc / pdoc-0.3.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Simple program and library to auto generate API documentation for Python modules"
11 HOMEPAGE="https://pypi.org/project/pdoc/ https://github.com/BurntSushi/pdoc"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="Unlicense"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17
18 RDEPEND="
19         dev-python/mako[${PYTHON_USEDEP}]
20         dev-python/markdown[${PYTHON_USEDEP}]
21         dev-python/pygments[${PYTHON_USEDEP}]
22 "
23 DEPEND="${RDEPEND}"
24
25 python_prepare_all() {
26         # Markdown < 2.5 is only for Python 2.6 support, which we don't support
27         sed \
28                 -e "s|markdown < 2.5|markdown|" \
29                 -e "s|share/pdoc|share/doc/${PF}|" \
30                 -e "s|'UNLICENSE', ||" \
31                 -i setup.py || die "sed failed"
32
33         distutils-r1_python_prepare_all
34 }