sys-apps/groff: stable 1.22.4 for hppa, bug #704420
[gentoo.git] / dev-python / patch-ng / patch-ng-1.17.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 DISTUTILS_USE_SETUPTOOLS=rdepend
8 inherit distutils-r1
9
10 DESCRIPTION="Library to parse and apply unified diffs, fork of dev-python/patch"
11 HOMEPAGE="https://github.com/conan-io/python-patch-ng https://pypi.org/project/patch-ng/"
12 SRC_URI="https://github.com/conan-io/python-patch-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17
18 distutils_enable_tests unittest
19
20 S="${WORKDIR}/python-${P}"
21
22 python_test() {
23         "${EPYTHON}" -m unittest tests/run_tests.py || die "Tests failed under ${EPYTHON}"
24 }