dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / dev-python / pastedeploy / pastedeploy-2.0.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
8
9 inherit distutils-r1
10
11 MY_PN="PasteDeploy"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Load, configure, and compose WSGI applications and servers"
15 HOMEPAGE="https://pypi.org/project/PasteDeploy/"
16 # pypi tarball does not include tests
17 SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz ->  ${P}.tar.gz"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
22 IUSE="doc"
23
24 RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]"
25 BDEPEND="${RDEPEND}"
26
27 distutils_enable_tests pytest
28
29 python_prepare_all() {
30         sed -i 's:"pytest-runner"::' setup.py || die
31
32         distutils-r1_python_prepare_all
33 }
34
35 python_install_all() {
36         distutils-r1_python_install_all
37
38         use doc && dodoc docs/*.txt
39         find "${D}" -name '*.pth' -delete || die
40 }