profiles/arch/amd64-fbsd/todo: force pulseaudio on firefox, bug 562412
[gentoo.git] / dev-python / passlib / passlib-1.6.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Password hashing framework supporting over 20 schemes"
11 HOMEPAGE="https://code.google.com/p/passlib/"
12 SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD-2"
15 KEYWORDS="amd64 x86"
16 SLOT="0"
17 IUSE="test doc"
18
19 RDEPEND="dev-python/bcrypt[${PYTHON_USEDEP}]"
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         ${RDEPEND}
22         test? ( dev-python/nose[${PYTHON_USEDEP}]
23                 )"
24
25 python_test() {
26         # https://code.google.com/p/passlib/issues/detail?id=50
27         # py3 on testing choaks on the suite
28         if ! python_is_python3; then
29                 nosetests -w "${BUILD_DIR}"/lib \
30                         -e test_90_django_reference -e test_91_django_generation \
31                         -e test_77_fuzz_input -e test_config \
32                         -e test_registry.py || die "Tests fail with ${EPYTHON}"
33         fi
34 }
35
36 python_install_all() {
37         distutils-r1_python_install_all
38         use doc && dodoc docs/{*.rst,requirements.txt,lib/*.rst}
39 }