sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / parver / parver-0.3.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 inherit distutils-r1
8
9 DESCRIPTION="Parse and manipulate version numbers"
10 HOMEPAGE="https://github.com/RazerM/parver https://pypi.org/project/parver/"
11 SRC_URI="https://github.com/RazerM/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="
18         >=dev-python/arpeggio-1.7[${PYTHON_USEDEP}]
19         dev-python/attrs[${PYTHON_USEDEP}]
20         dev-python/six[${PYTHON_USEDEP}]
21         "
22
23 DEPEND="
24         test? (
25                 ${RDEPEND}
26                 dev-python/hypothesis[${PYTHON_USEDEP}]
27                 dev-python/pretend[${PYTHON_USEDEP}]
28         )"
29
30 distutils_enable_tests pytest
31
32 PATCHES=(
33         # https://github.com/RazerM/parver/pull/6
34         "${FILESDIR}"/${P}-test.patch
35 )
36
37 src_prepare() {
38         # unlock dependencies
39         sed -i -e 's:~=:>=:g' setup.py || die
40
41         distutils-r1_src_prepare
42 }