x11-themes/gentoo10-backgrounds: Cleanup per bug #85210
[gentoo.git] / dev-python / packaging / packaging-15.3-r2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3  )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Core utilities for Python packages"
12 HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 SLOT="0"
16 LICENSE="Apache-2.0"
17 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 IUSE="test"
19
20 RDEPEND=""
21 DEPEND="${RDEPEND}
22         test? (
23                 dev-python/pretend[${PYTHON_USEDEP}]
24                 dev-python/pytest[${PYTHON_USEDEP}]
25         )
26 "
27
28 PATCHES=( "${FILESDIR}"/${P}-distutils.patch )
29
30 python_test() {
31         py.test --capture=no --strict -v || die
32 }
33
34 pkg_preinst() {
35         # Remove this in the next version bump
36         _cleanup() {
37                 local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
38                 local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
39                 if [[ -d ${egginfo} ]]; then
40                         echo rm -r "${egginfo}"
41                         rm -r "${egginfo}" || die "Failed to remove egg-info directory"
42                 fi
43         }
44         python_foreach_impl _cleanup
45 }