www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-python / os-client-config / os-client-config-1.32.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="OpenStack Client Configuation Library"
10 HOMEPAGE="https://www.openstack.org/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE=""
17
18 CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
19 DEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         ${CDEPEND}
22 "
23 RDEPEND="
24         ${CDEPEND}
25         >=dev-python/openstacksdk-0.13.0[${PYTHON_USEDEP}]
26 "
27
28 PATCHES=(
29         "${FILESDIR}"/test_get_all_clouds.patch
30 )
31
32 python_prepare_all() {
33         sed -i '/^hacking/d' test-requirements.txt || die
34         distutils-r1_python_prepare_all
35 }