dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / nose_warnings_filters / nose_warnings_filters-0.1.5-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A python module to inject warning filters during nosetest"
11 HOMEPAGE="https://github.com/Carreau/nose_warnings_filters"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
17 IUSE="test"
18
19 RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( ${RDEPEND} )"
23
24 python_test() {
25         # nose_warnings_filters doesn't have a proper
26         # testing suite, hence we run the only testing
27         # script available
28         distutils_install_for_testing
29         cd "${TEST_DIR}"/lib || die
30         "${EPYTHON}" "${S}"/${PN}/testing/test_config.py || die "Failed running test script"
31 }