45a8c09a118f583283dc843f3d952e49683efc70
[gentoo.git] / dev-python / nose-exclude / nose-exclude-0.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Exclude specific directories from nosetests runs"
11 HOMEPAGE="https://github.com/kgrandis/nose-exclude"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-2.1"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
20
21 python_test() {
22         esetup.py test
23 }