dev-python/backports-unittest-mock: ppc stable (bug 613096).
[gentoo.git] / dev-python / netlib / netlib-0.11.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1 versionator
8
9 DESCRIPTION="Collection of network utility classes used by pathod and mitmproxy"
10 HOMEPAGE="https://github.com/cortesi/netlib/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND=">=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
19         >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
20         >=dev-python/passlib-1.6.2[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         test? (
23                 >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
24                 >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
25                 =www-servers/pathod-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
26         )"
27
28 python_test() {
29         nosetests -v || die "Tests fail with ${EPYTHON}"
30 }