dev-python/backports-unittest-mock: ppc stable (bug 613096).
[gentoo.git] / dev-python / netlib / netlib-0.10.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Collection of network utility classes used by pathod and mitmproxy"
10 HOMEPAGE="https://github.com/cortesi/netlib/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND=">dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
19         >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]"
20 DEPEND="${RDEPEND}
21         test? (
22                 >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
23                 >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
24                 www-servers/pathod[${PYTHON_USEDEP}]
25         )"
26
27 python_test() {
28         nosetests -v || die "Tests fail with ${EPYTHON}"
29 }