dev-libs/libgpg-error: New upstream version 1.26
[gentoo.git] / dev-python / netcdf4-python / netcdf4-python-1.0.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit distutils-r1
10
11 MY_PN="netCDF4"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="Python/numpy interface to netCDF"
15 HOMEPAGE="https://github.com/Unidata/netcdf4-python"
16 SRC_URI="https://netcdf4-python.googlecode.com/files/${MY_P}.tar.gz"
17
18 SLOT="0"
19 LICENSE="MIT"
20 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
21 IUSE="test"
22
23 RDEPEND="
24         sci-libs/hdf5
25         sci-libs/netcdf:=[hdf]"
26 DEPEND="${RDEPEND}"
27
28 S="${WORKDIR}"/${MY_P}
29
30 python_test() {
31         cd test || die
32         ${PYTHON} run_all.py || die
33 }