sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-python / netaddr / netaddr-0.7.19.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Network address representation and manipulation library"
11 HOMEPAGE="https://github.com/drkjam/netaddr https://pypi.org/project/netaddr/ https://netaddr.readthedocs.org"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
17 IUSE="cli test"
18 RESTRICT="!test? ( test )"
19 REQUIRED_USE="cli? ( || ( $(python_gen_useflags -3) ) )"
20
21 RDEPEND="
22         cli? (
23                 >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}]
24         )"
25 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
26         test? (
27                 dev-python/pytest[${PYTHON_USEDEP}]
28                 ${RDEPEND}
29         )"
30
31 python_test() {
32         esetup.py test
33 }