dev-python/logbook: Clean old versions up
[gentoo.git] / dev-python / neovim-python-client / neovim-python-client-0.1.11.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
6 inherit distutils-r1
7
8 DESCRIPTION="Python client for Neovim"
9 HOMEPAGE="https://github.com/neovim/python-client"
10 SRC_URI="https://github.com/neovim/python-client/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64"
15
16 DEPEND="
17         >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
18         virtual/python-greenlet[${PYTHON_USEDEP}]
19         $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
20 "
21
22 RDEPEND="
23         ${DEPEND}
24         >=app-editors/neovim-0.1.6
25 "
26
27 S="${WORKDIR}/python-client-${PV}"