43af35d5e2639961007e8a8d4b884212faf5f8bc
[gentoo.git] / dev-python / neovim-python-client / neovim-python-client-0.0.38.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_4} )
6 inherit distutils-r1
7
8 DESCRIPTION="Python client for Neovim"
9 HOMEPAGE="https://github.com/neovim/python-client"
10 SRC_URI="https://dev.gentoo.org/~tranquility/distfiles/${P}.tar.xz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="gtk"
16 REQUIRED_USE="gtk? ( python_targets_python2_7 )" # experimental gui only works with py2
17
18 DEPEND="
19         >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
20         virtual/python-greenlet[${PYTHON_USEDEP}]
21         $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
22         gtk? (
23                 >=dev-python/click-3.0[${PYTHON_USEDEP}]
24                 dev-python/pygobject:2
25                 dev-python/pygtk:2
26                 x11-libs/gtk+:2[introspection]
27         )"
28 RDEPEND="${DEPEND}"