dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / nbval / nbval-0.9.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
11 HOMEPAGE="https://github.com/computationalmodelling/nbval"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 RDEPEND="
21         dev-python/pytest[${PYTHON_USEDEP}]
22         dev-python/six[${PYTHON_USEDEP}]
23         dev-python/jupyter_client[${PYTHON_USEDEP}]
24         dev-python/nbformat[${PYTHON_USEDEP}]
25         dev-python/ipykernel[${PYTHON_USEDEP}]
26         "
27 DEPEND="${RDEPEND}
28         test? (
29                 dev-python/sympy[${PYTHON_USEDEP}]
30                 dev-python/matplotlib[${PYTHON_USEDEP}]
31         )"