6aaf7a59c2db7777192de9acf9935cdadfc32ee5
[gentoo.git] / dev-python / natgrid / natgrid-0.2.1-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Matplotlib toolkit for gridding irreguraly spaced data"
11 HOMEPAGE="http://matplotlib.sourceforge.net/users/toolkits.html"
12 SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE=""
18
19 DEPEND=">=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]"
20 RDEPEND="${DEPEND}"
21
22 python_install_all() {
23         insinto /usr/share/doc/${PF}
24         doins test.py
25         distutils-r1_python_install_all
26 }
27
28 python_install() {
29         # namespace installed by dev-python/matplotlib
30         rm "${BUILD_DIR}/lib/mpl_toolkits/__init__.py" || die
31         distutils-r1_python_install --skip-build
32 }