dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / mysql-python / mysql-python-1.2.3-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1 flag-o-matic
8
9 MY_P="MySQL-python-${PV}"
10
11 DESCRIPTION="Python interface to MySQL"
12 HOMEPAGE="https://sourceforge.net/projects/mysql-python/ https://pypi.python.org/pypi/MySQL-python"
13 SRC_URI="mirror://sourceforge/mysql-python/${MY_P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
18 IUSE=""
19
20 RDEPEND="virtual/mysql"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]"
23
24 S="${WORKDIR}/${MY_P}"
25
26 DOCS=( HISTORY README doc/{FAQ,MySQLdb}.txt )
27
28 python_configure_all() {
29         append-flags -fno-strict-aliasing
30 }