dev-python/wsgiproxy2: Keyword 0.4.6-r1 ppc, #726188
[gentoo.git] / dev-python / mpmath / mpmath-1.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
11 HOMEPAGE="http://mpmath.org/"
12 SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
17
18 IUSE="gmp matplotlib test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         gmp? ( dev-python/gmpy )
23         matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
24 DEPEND="${RDEPEND}
25         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
26
27 python_prepare_all() {
28         local PATCHES=(
29                 "${FILESDIR}/${PN}-1.0.0.patch"
30                 )
31
32         # this test requires X
33         rm ${PN}/tests/test_visualization.py || die
34
35         distutils-r1_python_prepare_all
36 }
37
38 python_test() {
39         pushd ${PN}/tests >/dev/null
40         ${EPYTHON} runtests.py -local
41         popd >/dev/null
42 }