dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / mox3 / mox3-0.24.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Mock object framework for Python"
10 HOMEPAGE="http://www.openstack.org/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE="doc test"
17
18 CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
19 CRDEPEND=">=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]"
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         ${CDEPEND}
23         test? (
24                 ${CRDEPEND}
25                 >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
26                 >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
27                 >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
28                 >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
29         )
30         doc? (
31                 >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
32                 >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
33                 >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
34         )
35 "
36 RDEPEND="
37         ${CDEPEND}
38         ${CRDEPEND}
39 "
40
41 PATCHES=( "${FILESDIR}"/${PN}-0.12.0-RegexTest-python3.6.patch )
42
43 python_compile_all() {
44         use doc && esetup.py build_sphinx
45 }
46
47 python_test() {
48         rm -rf .testrepository || die "could not remove '.testrepository' under ${EPYTHON}"
49
50         testr init || die "testr init failed under ${EPYTHON}"
51         testr run || die "testr run failed under ${EPYTHON}"
52 }
53
54 python_install_all() {
55         use doc && local HTML_DOCS=( doc/build/html/. )
56
57         distutils-r1_python_install_all
58 }