dev-python/PyQt5: remove 5.12.1
[gentoo.git] / dev-python / mock / mock-2.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Rolling backport of unittest.mock for all Pythons"
11 HOMEPAGE="https://github.com/testing-cabal/mock"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
17 IUSE="test"
18
19 CDEPEND="
20         >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
21         >=virtual/python-funcsigs-1[${PYTHON_USEDEP}]"
22 DEPEND="
23         >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
24         test? (
25                 ${CDEPEND}
26                 dev-python/nose[${PYTHON_USEDEP}]
27                 >=dev-python/unittest2-1.1.0[${PYTHON_USEDEP}]
28         )"
29 RDEPEND="
30         ${CDEPEND}
31         >=dev-python/six-1.9[${PYTHON_USEDEP}]
32 "
33
34 python_test() {
35         nosetests --verbose || die "tests fail under ${EPYTHON}"
36 }
37
38 python_install_all() {
39         local DOCS=( docs/{conf.py,index.txt} AUTHORS ChangeLog NEWS README.rst )
40
41         distutils-r1_python_install_all
42 }