dev-cpp/gtest: mark s390 stable
[gentoo.git] / dev-python / minidb / minidb-2.0.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_{4,5,6} )
7 PYTHON_REQ_USE="sqlite"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Simple SQLite-based object store"
12 HOMEPAGE="https://thp.io/2010/minidb/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="ISC"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="test"
19
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( dev-python/nose[${PYTHON_USEDEP}] )
23 "
24
25 python_test() {
26         nosetests test || die "tests failed with ${EPYTHON}"
27 }