dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / micawber / micawber-0.5.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 inherit distutils-r1
8
9 DESCRIPTION="A small library for extracting rich content from urls"
10 HOMEPAGE="https://github.com/coleifer/micawber/"
11 SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="amd64"
16 IUSE="test"
17 RESTRICT="!test? ( test )"
18
19 BDEPEND="
20         test? (
21                 $(python_gen_impl_dep sqlite)
22                 dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
23                 dev-python/django[${PYTHON_USEDEP}]
24         )"
25
26 python_test() {
27         "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
28 }