93d90fa6bf688a5595a8b93055dde45d6c5b7e96
[gentoo.git] / dev-python / mechanize / mechanize-0.3.6.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Stateful programmatic web browsing in Python"
11 HOMEPAGE="https://github.com/python-mechanize/mechanize"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="|| ( BSD ZPL )"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
17 IUSE="doc"
18
19 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 RDEPEND="${DEPEND}"
21
22 python_test() {
23         "${PYTHON}" run_tests.py || die
24 }