dev-python/mccabe: PYTHON_COMPAT: add python3_6
[gentoo.git] / dev-python / mccabe / mccabe-0.6.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="flake8 plugin: McCabe complexity checker"
12 HOMEPAGE="https://github.com/PyCQA/mccabe"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 IUSE="test"
17 LICENSE="MIT"
18 SLOT="0"
19
20 RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
22         test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
23
24 python_prepare_all() {
25         sed -i -e '/pytest-runner/d' setup.py || die
26         distutils-r1_python_prepare_all
27 }
28
29 python_test() {
30         py.test -v || die "Testing failed with ${EPYTHON}"
31 }