Merge remote-tracking branch 'github/pr/268'
[gentoo.git] / dev-python / mamba / mamba-0.8.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 python3_4 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="The definitive testing tool for Python. Born under the banner of Behavior Driven Development"
11 HOMEPAGE="http://nestorsalceda.github.io/mamba"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="test"
18
19 CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
20 DEPEND="
21         ${CDEPEND}
22         test? (
23                 ~dev-python/doublex-expects-0.7.0_rc1[${PYTHON_USEDEP}]
24                 ~dev-python/expects-0.8.0_rc2[${PYTHON_USEDEP}]
25                 ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
26         )
27 "
28 RDEPEND="
29         ${CDEPEND}
30         ~dev-python/clint-0.3.1[${PYTHON_USEDEP}]
31         ~dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
32         ~dev-python/watchdog-0.8.1[${PYTHON_USEDEP}]
33 "
34
35 python_test() {
36         "${PYTHON}" -m mamba.cli || die "Tests failed under ${EPYTHON}"
37 }