sys-devel/lld: Port 9+ to llvm.org.eclass
[gentoo.git] / dev-python / lit / lit-9.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
7 inherit distutils-r1 llvm.org multiprocessing
8
9 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
10 HOMEPAGE="https://llvm.org/"
11 LLVM_COMPONENTS=( llvm/utils/lit )
12 llvm.org_set_globals
13
14 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 # Tests require 'FileCheck' and 'not' utilities (from llvm)
21 BDEPEND="
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? (
24                 dev-python/psutil[${PYTHON_USEDEP}]
25                 sys-devel/llvm )"
26
27 # TODO: move the manpage generation here (from sys-devel/llvm)
28
29 python_test() {
30         local -x LIT_PRESERVES_TMP=1
31         ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
32                 -vv tests || die
33 }