sys-devel/llvm: 10.x branch is now 10.0.1
[gentoo.git] / dev-python / lit / lit-10.0.1.9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
8
9 inherit distutils-r1 llvm.org multiprocessing
10
11 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
12 HOMEPAGE="https://llvm.org/"
13 LLVM_COMPONENTS=( llvm/utils/lit )
14 llvm.org_set_globals
15
16 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="test"
20 RESTRICT="!test? ( test )"
21
22 # Tests require 'FileCheck' and 'not' utilities (from llvm)
23 BDEPEND="
24         test? (
25                 dev-python/psutil[${PYTHON_USEDEP}]
26                 sys-devel/llvm )"
27
28 # TODO: move the manpage generation here (from sys-devel/llvm)
29
30 python_test() {
31         local -x LIT_PRESERVES_TMP=1
32         ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
33                 -vv tests || die
34 }