dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / libwnck-python / libwnck-python-2.32.0-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 GNOME_ORG_MODULE="gnome-python-desktop"
7 G_PY_BINDINGS="wnck"
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit gnome-python-common-r1 eutils
11
12 DESCRIPTION="Python bindings for the libwnck library"
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
16 IUSE="examples"
17
18 RDEPEND=">=x11-libs/libwnck-2.19.3:1
19         !<dev-python/gnome-python-desktop-2.22.0-r10"
20 DEPEND="${RDEPEND}"
21
22 EXAMPLES=( examples/wnck_example.py )
23
24 src_prepare() {
25         # Fix three enum items that should be flags, upstream bug #616306
26         epatch "${FILESDIR}/${PN}-2.30.2-flagsfix.patch"
27         gnome-python-common-r1_src_prepare
28 }