dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / libbonobo-python / libbonobo-python-2.28.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 GNOME_ORG_MODULE="gnome-python"
7 G_PY_BINDINGS=( bonobo bonoboui bonobo_activation )
8 PYTHON_COMPAT=( python2_7 )
9
10 inherit gnome-python-common-r1
11
12 DESCRIPTION="Python bindings for the Bonobo framework"
13 LICENSE="LGPL-2.1"
14 SLOT="2"
15 KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
16 IUSE="examples"
17
18 RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
19         >=dev-python/pyorbit-2.24.0[${PYTHON_USEDEP}]
20         >=gnome-base/libbonobo-2.24.0
21         >=gnome-base/libbonoboui-2.24.0
22         >=dev-python/libgnomecanvas-python-${PV}[${PYTHON_USEDEP}]
23         !<dev-python/gnome-python-2.22.1"
24 DEPEND="${RDEPEND}"
25
26 EXAMPLES=( examples/bonobo/. )