dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / lesscpy / lesscpy-0.9j.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A compiler written in Python for the LESS language"
10 HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="test"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
19 RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
20
21 python_test() {
22         ${PYTHON} lesscpy/test/__main__.py || die "test failed under ${EPYTHON}"
23 }