dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / lesscpy / lesscpy-0.13.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
6
7 inherit distutils-r1
8
9 # incomplete tarball
10 RESTRICT="test"
11
12 DESCRIPTION="A compiler written in Python for the LESS language"
13 HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="test"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
23                 dev-python/six[${PYTHON_USEDEP}]"
24
25 python_test() {
26         # https://github.com/lesscpy/lesscpy/issues/74
27         esetup.py test
28         # This is equally effective
29         # nosetests -v || die "tests failed under ${EPYTHON}"
30 }