dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / dev-python / ldap3 / ldap3-2.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
11 HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
12 SRC_URI="https://github.com/cannatag/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 RDEPEND="
19         >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
20 "
21 # tests require a ldap server and extra configuration
22 RESTRICT="test"
23
24 distutils_enable_tests nose