Merge remote-tracking branch 'github/pr/827'.
[gentoo.git] / dev-python / ldap3 / ldap3-1.0.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
8
9 inherit distutils-r1
10
11 DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
12 HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="LGPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="test"
19
20 RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22         dev-python/setuptools[${PYTHON_USEDEP}]
23         test? ( dev-python/nose[${PYTHON_USEDEP}] )
24         "
25
26 python_test() {
27         cd "${BUILD_DIR}" || die
28         nosetests -v -s test || die
29 }