proj/gentoo: Initial commit
[gentoo.git] / dev-python / keyring / keyring-3.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python2_7 python{3_3,3_4} pypy)
7
8 inherit distutils-r1
9 DESCRIPTION="Provides access to the system keyring service"
10 HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
11 SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
12
13 LICENSE="PSF-2"
14 KEYWORDS="amd64 x86"
15 SLOT="0"
16 IUSE="test"
17
18 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
19                 app-arch/unzip
20         test? ( dev-python/pytest-runner[${PYTHON_USEDEP}]
21                 dev-python/pytest[${PYTHON_USEDEP}]
22                 dev-python/mock[${PYTHON_USEDEP}]
23                 dev-python/pycrypto[$(python_gen_usedep 'python2*' 'python3*')] )"
24 RDEPEND=""
25
26 python_test() {
27         py.test || die "testsuite failed under ${EPYTHON}"
28 }