dev-python/kombu: 4.6.8 allarches stablized
[gentoo.git] / dev-python / keyring / keyring-21.2.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7 PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Provides access to the system keyring service"
12 HOMEPAGE="https://github.com/jaraco/keyring"
13 SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14
15 SLOT="0"
16 LICENSE="PSF-2"
17 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
18 IUSE="doc"
19
20 RDEPEND="
21         dev-python/secretstorage[${PYTHON_USEDEP}]
22         dev-python/entrypoints[${PYTHON_USEDEP}]
23         dev-python/jeepney[${PYTHON_USEDEP}]
24         $(python_gen_cond_dep '
25                 dev-python/importlib_metadata[${PYTHON_USEDEP}]
26         ' pypy3 python3_{5,6,7})
27 "
28 BDEPEND="
29         dev-python/setuptools_scm[${PYTHON_USEDEP}]
30         dev-python/toml[${PYTHON_USEDEP}]
31 "
32
33 distutils_enable_tests pytest
34 distutils_enable_sphinx docs \
35         dev-python/jaraco-packaging \
36         dev-python/rst-linker
37
38 python_prepare_all() {
39         sed -i -e 's:--flake8 --black --cov::' pytest.ini || die
40         # relies on cpython's gc behavior
41         sed -i -e 's:test_traceback_not_referenced:_&:' \
42                 tests/test_errors.py || die
43
44         rm tests/backends/test_kwallet.py || die
45
46         distutils-r1_python_prepare_all
47
48         export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
49 }