dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / keyczar / keyczar-0.715.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python2_7 )     #appears py2 friendly only
6
7 inherit distutils-r1
8
9 MY_PN=python-${PN}
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="Toolkit for safe and simple cryptography"
13 HOMEPAGE="http://www.keyczar.org https://pypi.python.org/pypi/python-keyczar/"
14 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="Apache-2.0"
17 SLOT="0"
18 KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 x86"
19 IUSE="doc"
20
21 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
22 RDEPEND="${DEPEND}
23         >=dev-python/pycrypto-2.0[${PYTHON_USEDEP}]
24         dev-python/pyasn1[${PYTHON_USEDEP}]"
25
26 S=${WORKDIR}/${MY_P}
27
28 python_test() {
29         cd tests/keyczar_tests
30         ${PYTHON} alltests.py || die "tests fail with ${EPYTHON}"
31 }
32
33 python_install_all() {
34         use doc && dodoc doc/pycrypt*
35
36         distutils-r1_python_install_all
37 }