dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / keepassx / keepassx-0.1.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python API and CLI for KeePassX"
11 HOMEPAGE="https://github.com/jamesls/python-keepassx https://pypi.python.org/pypi/keepassx"
12 SRC_URI="https://github.com/jamesls/python-keepassx/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 SLOT="0"
15 LICENSE="GPL-2"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 S=${WORKDIR}/python-${P}
20
21 RDEPEND="
22         || (
23                 dev-python/pycryptodome[${PYTHON_USEDEP}]
24                 dev-python/pycrypto[${PYTHON_USEDEP}]
25         )
26         dev-python/prettytable[${PYTHON_USEDEP}]
27         dev-python/pyyaml[${PYTHON_USEDEP}]
28         dev-python/six[${PYTHON_USEDEP}]
29 "
30 DEPEND="${RDEPEND}
31         dev-python/setuptools[${PYTHON_USEDEP}]
32         test? ( dev-python/pytest[${PYTHON_USEDEP}]
33                 dev-python/mock[${PYTHON_USEDEP}] )
34 "
35 python_test() {
36         py.test tests || die
37 }