dev-perl/Class-Inspector: amd64 stable
[gentoo.git] / dev-python / json-tools / json-tools-0.4.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # 'Programming Language :: ...  in setup.py requires updating"
7 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
8 inherit distutils-r1
9
10 MY_PN="json_tools"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="A set of tools to manipulate JSON: diff, patch, and pretty-printing"
14 HOMEPAGE="https://pypi.python.org/pypi/json_tools https://bitbucket.org/vadim_semenov/json_tools"
15 SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="amd64 x86"
20 IUSE="test"
21
22 RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]
23         dev-python/setuptools[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         test? ( dev-python/nose[${PYTHON_USEDEP}] )"
26
27 S=${WORKDIR}/${MY_P}
28
29 python_test() {
30         nosetests || die "Tests fail with ${EPYTHON}"
31 }