39a2bb5c913d784e7b31f96e8747f26e028f82f7
[gentoo.git] / dev-python / ipython_genutils / ipython_genutils-0.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Vestigial utilities from IPython"
11 HOMEPAGE="https://github.com/ipython/ipython_genutils"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="
21         test? (
22                 dev-python/nose[${PYTHON_USEDEP}]
23                 dev-python/coverage[${PYTHON_USEDEP}]
24         )
25         "
26
27 python_test() {
28         nosetests --with-coverage --cover-package=ipython_genutils ipython_genutils || die
29 }